We are doing everything we can to restore service.
Thank you.
Posted Jun 12, 2025 - 15:05 EDT
Identified
Google Cloud is down globally. Many public services are currently affected.
Posted Jun 12, 2025 - 14:27 EDT
Investigating
We are receiving numerous reports that users are unable to log in to web and mobile applications. The error "Invalid e-mail address or password" is displayed
Inbound and Outbound messaging appears to be unaffecfted.
We are investigating
Posted Jun 12, 2025 - 14:17 EDT
This incident affected: Retail Platform (Application) and Private Label Platform (Application).