User Management Operations are Failing

Incident Report for Textable

Identified

We are working with our billing vendor to restore the integration that supports our user management operations.

We are also developing an application patch to gracefully handle billing update failures in a way that does not block user management operations.
Posted May 27, 2026 - 13:54 EDT

Investigating

We've received a number of reports that adding / editing / deleting users is failing.

We've identified an issue with our billing platform causing synchronous rejections of updates to billing details.

We are working towards a resolution
Posted May 27, 2026 - 12:51 EDT
This incident affects: Retail Platform (Application) and Private Label Platform (Application).